DPlot Forum Index DPlot
http://www.dplot.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Must reformat csv date format prior to appending

 
Post new topic   Reply to topic    DPlot Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
usfscooter



Joined: 25 Jul 2006
Posts: 3

PostPosted: Tue Jul 25, 2006 9:21 am    Post subject: Must reformat csv date format prior to appending Reply with quote

In a previous version of DPlot I had been able to successfully append a csv file. This is an automatically generated csv file from DAQ software. When I try to append and use the 'pick columns to plot' I can see that DPlot recognizes the time/date info. When I append it, I get no data and the first time/date displayed is 12/30/1899 12:00:00 AM. The csv files are too large to open in Excel, so I have to chop it up in Word in order to reformat it. This is very frustrating especially since I never had to do that before. I am currently running ver 2.0.6. Any help you can offer would be greatly appreciated.
Back to top
View user's profile Send private message
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2290
Location: Vicksburg, Mississippi

PostPosted: Tue Jul 25, 2006 10:33 am    Post subject: Reply with quote

Sorry for the trouble, but that's not the behavior I'm seeing when I try this. If you can send me a couple of files that are giving you problems, that would probably be helpful. Whatever the problem is it is almost certainly not related to the file size, so you can just send the first few thousand lines or so.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2290
Location: Vicksburg, Mississippi

PostPosted: Tue Jul 25, 2006 1:38 pm    Post subject: Reply with quote

Thanks for the file. I've apparently made a recent goof in handling quoted values. If I eliminate the quotes and delete your 2nd column, all works as expected. I'll have this fixed as soon as possible.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
usfscooter



Joined: 25 Jul 2006
Posts: 3

PostPosted: Wed Jul 26, 2006 8:26 am    Post subject: Reply with quote

Thank you for your timely response. I look forward to the fix.
Back to top
View user's profile Send private message
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2290
Location: Vicksburg, Mississippi

PostPosted: Sat Jul 29, 2006 12:09 am    Post subject: Reply with quote

Fixed. Sorry for the trouble, but thanks for pointing out the problem. You can get the update by selecting Help>Check for Updates, or if you're on the mailing list you'll be receiving instructions soon.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
usfscooter



Joined: 25 Jul 2006
Posts: 3

PostPosted: Mon Jul 31, 2006 8:18 am    Post subject: Reply with quote

Thanks. It works great.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    DPlot Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group