DPlot Forum Index DPlot
http://www.dplot.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Croping issues, part deux

 
Post new topic   Reply to topic    DPlot Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
John Horrigan



Joined: 07 Apr 2008
Posts: 16

PostPosted: Tue Jun 02, 2009 5:08 pm    Post subject: Croping issues, part deux Reply with quote

Hi David. The good news is that cropping now captures the correct area, even when the scale is reversed.

The 'other' news is that the cropped output looks like it has been reflected in the x axis (as though the y scale was no longer negative), and the Z and Y values have shifted.

For example, if I crop the upper left corner of a 200 x 200 graph to capture the area Y from 0 to 30, x from 0 to 100, I will end up with a rotated product with a range from 70 to 200 on Y, 100 to 200 on X.

The grf file I sent you should still work for this case, please let me know if you'd like a fresh copy.

Thanks again
-john
Back to top
View user's profile Send private message
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2130
Location: Vicksburg, Mississippi

PostPosted: Wed Jun 03, 2009 12:29 am    Post subject: Reply with quote

Hmm... I made a dozen or so attempts with your example (with scale factors 1,-1,1) and get the expected results. I also switched the X scale factor to -1 to see if I might have fouled that up, but no - I still get the extents I asked for and the correct data.

One possibility: if you checked "Use actual displayed limits" on the Contour Options dialog, then the colors might change after cropping and might confuse you for a moment.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
John Horrigan



Joined: 07 Apr 2008
Posts: 16

PostPosted: Wed Jun 03, 2009 11:12 am    Post subject: Reply with quote

Thanks David. I found the problem. Something must have hung up during my install of the new version, I checked today and the version number had not updated. I re-attempted the install successfully and it works!

Sorry for the inconvenience.... Embarassed

-John
Back to top
View user's profile Send private message
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2130
Location: Vicksburg, Mississippi

PostPosted: Wed Jun 03, 2009 11:33 am    Post subject: Reply with quote

No inconvenience at all - thanks for the reply.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    DPlot Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group