DPlot Forum Index DPlot
http://www.dplot.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Crashes when tiling multiple plots are open

 
Post new topic   Reply to topic    DPlot Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
ssaliga



Joined: 29 May 2009
Posts: 2

PostPosted: Fri May 29, 2009 12:15 pm    Post subject: Crashes when tiling multiple plots are open Reply with quote

Within the last few revs of DPlot, I have had trouble with DPlot crashing when I try to open multiple plots and perhaps tile them to see them all together. I am running Windows XP Professional, have turned off all my security applications, etc. I wanted to go back and try an "older" version but don't have that ability. Any other thoughts?

Thanks,

Steve
Back to top
View user's profile Send private message
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2095
Location: Vicksburg, Mississippi

PostPosted: Sun May 31, 2009 1:02 pm    Post subject: Reply with quote

The good news (depending on how you look at it) is that I'm getting the same problem here. Haven't solved it yet, but I think this likely has something to do with a recent change of not erasing the background of child documents when the window is resized (in this case tiled). Will fix as soon as possible.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2095
Location: Vicksburg, Mississippi

PostPosted: Sun May 31, 2009 3:25 pm    Post subject: Reply with quote

Steve,
I have one test case where the results are mostly repeatable (run a macro that opens all the DPlot files in my test folder and tile the documents (21 of them). Maximize any child document, then click the Restore button. Boom - at least 4 times out of 5.) That's the good news.

The problem has nothing to do with the fairly recent change with regards to erasing the background when a plot is redrawn (that's the bad news).

I don't want to put you on the spot and/or turn you into a guinea pig on this, and really this is as much about writing things down hoping something hops out at me as much as it is about asking you questions. But a couple of answers could help here:

1) How many documents are you working with?
2) What plot types? (If XY plots, for example, what scaling? If 3D data, are you viewing in 3D or not?, etc.)

I'm pretty sure I know the culprit and the answer but don't want to influence your answer.

Thanks for your input.
_________________
David Hyde
support@dplot.com


Last edited by DPlotAdmin on Mon Jun 01, 2009 8:16 am; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ssaliga



Joined: 29 May 2009
Posts: 2

PostPosted: Mon Jun 01, 2009 7:21 am    Post subject: Crashes when tiling multiple plots are open Reply with quote

David:

Version 2.2.5.8. still exhibits the problem.

I am working with Polar Plots, up to 12 of them at a time, but usually 4 or 6. Each polar graph shows 3 plots so there are a total of 360 data points with some simple text for the title and a three line legend on each graph.

The problem occurs virtually every time I try to open multiple files and happens 9 times out of ten when I have one open already and then start making more plots. Sometimes DPlot crashes in the middle of the plot making process or even when a file has just finished the "save" process.

I am running on a Thinkpad T60 mostly, but I also tried running on an HP xw9400 workstation and the problem followed me to that machine as well.

Steve
Back to top
View user's profile Send private message
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2095
Location: Vicksburg, Mississippi

PostPosted: Mon Jun 01, 2009 8:15 am    Post subject: Reply with quote

Polar plots I had figured, as my test only crashed when a polar plot was present. But the beta version I sent you fixed it. So bah Mad

Thanks for the details. Will let you know when I find something and fix it.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
DPlotAdmin
Site Admin


Joined: 24 Jun 2003
Posts: 2095
Location: Vicksburg, Mississippi

PostPosted: Mon Jun 01, 2009 5:37 pm    Post subject: Reply with quote

Problem fixed and new version uploaded. If you've been following this thread, the problem was with polar plots that included a legend. Mailing list mail is being sent as I type this. All licensed users can get the update (version 2.2.5.9) with "Check for Updates" on the Help menu.
_________________
David Hyde
support@dplot.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    DPlot Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group